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Descriptive Statistics 
Purpose:  To compute descriptive statistics (e.g., mean, standard deviation, minimum, maximum) for 
your variables.  (Descriptive statistics are shown in the output when you run many types of inferential 
statistical tests, so you may not need to compute only descriptive statistics very often, but here are 
instructions for doing so.) 

How to set up the data:  Each variable should be in its own column.  Each row contains data for a 
different subject. 

Example:  Compute descriptive statistics for Variable A and Variable B. 

Example data: 

 

 

How to compute descriptive statistics:   

1) Click on Analyze > Descriptive Statistics > Descriptives… to open the dialog box: 
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2) Move the variables for which you want descriptive statistics to “Variable(s)”: 

 

 
3) Click “Options…”  Check the boxes for the statistics you want to compute.  Mean, standard 

deviation, minimum, and maximum are already selected by default: 
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4) Click “Continue”.  Click “OK” in the “Descriptives” dialog box.  The results will appear in the 
Output window. 

 

How to read the output:  Each row of the Descriptive Statistics table contains the statistics for one of 
the variables. 

 

 

How to report the descriptive statistics in APA format: 

For this example:   

For Variable A, M = 5.20, SD = 2.28. 

  



EZ SPSS 4 U    6 

Correlation (Pearson Product-Moment Correlation Coefficient) 
Purpose:  To determine the strength and direction of linear relationship between two variables.  The p-
value that is reported by SPSS allows you to decide whether the correlation coefficient is significantly 
different from zero. 

How to set up the data:  SPSS can compute correlations between more than two variables at one time.  
If you submit more than two variables to the correlation procedure, the output will show the 
correlations between all possible pairs of the variables.  Each variable should be in a separate column, 
with values that belong together entered in the same row.   

Example:  Compute the correlations between Variables A and B, between Variables A and C, and 
between Variables B and C. 

Example data: 

 

 

How to run the test:   

1) Click on Analyze > Correlate > Bivariate…  The “Bivariate Correlations” dialog box appears: 
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2) Move all of the variables for which you want to compute correlations to the “Variables” box: 

 

 
 

3) Click “OK”.  The results will appear in the Output window. 
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How to read the output: 

The same correlation between each pair of variables is shown in two cells of the table: 

 

 

How to report the results in APA format: 

General format:  r(df) = #.##, p = .### 

Note that the table shows N rather than df.  For this test, df = N – 2. 

For this example: 

Correlation between A and B:  r(4) = 0.981, p < .001 

Correlation between A and C:  r(4) = 0.073, p = .891 

Correlation between B and C:  r(4) = -0.042, p = .936 

 

Note that the p-value reported by SPSS in the table is for a two-tailed (non-directional) test.  If you want 
to do a one-tailed (directional) test, either choose the “One-tailed” option in the “Bivariate Correlations” 
dialog box, or divide the two-tailed p-value by 2 to get the correct p-value. 

 

  

Correlation between 
Variables A and B. 

Correlation between 
Variables B and C. 

Correlation between 
Variables A and C. 

This value is N.  df = N - 2. 
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Independent-Samples t-test/Independent-Groups t-test 
Purpose:  To compare the means of two samples that contain independent observations of a variable 
(for example, for two different levels of an independent variable). 

How to set up the data:  One column should contain the variable being compared for the two 
groups/samples (the dependent variable, or DV).  Another column should contain an identifier that 
indicates to which group/sample the observation belongs.  Each row contains data for a different 
subject. 

Example:  Compare the mean reaction time for Group A and Group B. 

Example data: 

 

 

How to run the test:   

1) Click on Analyze > Compare Means > Independent-Samples T Test… to open the dialog box: 
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2) Move the DV to “Test Variable(s)” and move the grouping variable to “Grouping Variable”.  
(Check the “Estimate effect sizes” box at the bottom to calculate Cohen’s d): 

 

 
3) Click “Define Groups…”  Enter the two possible values of the grouping variable exactly as they 

appear in your spreadsheet (e.g., in terms of upper- and lower-case letters): 

 

 

4) Click “Continue”.  Click “OK” in the “Independent-Samples T Test” dialog box.  The results will 
appear in the Output window. 
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How to read the output: 

 

 

How to report the results in APA format: 

General format:  t(df) = #.##, p = .### 

For this example:  t(5) = 4.668, p = .005 

 

Note that the p-value reported by SPSS is for a two-tailed (non-directional) test.  If you are doing a one-
tailed (directional) test, you must divide the reported p-value by 2 to get the correct p-value. 

 

  

This table shows the 
descriptive statistics 
for your variable in 
your two groups. 

Cohen’s d (effect size) 
is shown in this cell.  In 
this example, Cohen’s 
d = 3.565. 
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Repeated-Measures t-test/Paired-Samples t-test/Related-Samples t-test 
Purpose:  To compare the means of two samples in which the same subjects contributed data to both 
samples (in a repeated-measures design) or if each subject in one group can be matched with one 
subject in the other group in a meaningful way (e.g., twins; brother and sister). 

How to set up the data:  One column should contain the values for one condition and another column 
should contain the values for the second condition, with values that belong together entered in the 
same row.  In a repeated-measures design, each row contains values for a single subject. 

Example:  Compare the mean score in Condition A to the mean score in Condition B. 

Example data: 

 

 

How to run the test:   

1) Click on Analyze > Compare Means > Paired-Samples T Test… to open the dialog box: 
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2) Move the name of the variable for one condition to the “Variable1” column and move the other 
variable name to the “Variable2” column.  (Check the “Estimate effect sizes” box at the bottom 
to calculate Cohen’s d.): 

 

 
 

3) Click “OK”.  The results will appear in the Output window. 
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How to read the output: 

 

 

How to report the results in APA format: 

General format:  t(df) = #.##, p = .### 

For this example:  t(5) = 8.216, p < .001 

 

Note that the p-value reported by SPSS is for a two-tailed (non-directional) test.  If you are doing a one-
tailed (directional) test, you must divide the reported p-value by 2 to get the correct p-value. 

 

  

This table shows the 
descriptive statistics 
for your variables. 

This table shows the correlation 
between your variables (in case 
you want that information). 

Cohen’s d (effect size) 
is shown in this cell.  In 
this example, Cohen’s 
d = 3.354. 
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One-Way Independent-Groups (Between-Subjects) ANOVA 
Purpose:  To compare the means of three or more samples that contain independent observations of a 
variable.  If the ANOVA produces significant results, do a post hoc test to determine specifically which 
sample means are different from each other. 

How to set up the data:  One column should contain the variable being compared for the 
groups/samples (the dependent variable, or DV).  Another column should contain an identifier that 
indicates to which group/sample the observation belongs.  Each row contains data for a different 
subject.  The grouping variable must be nominal and numeric. 

Example:  Compare the mean reaction times for Group 1, Group 2, and Group 3. 

Example data: 

 

 

How to run the test:   

1) Click on Analyze > Compare Means > One-Way ANOVA… to open the dialog box: 
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2) Move the DV to “Dependent List” and move the grouping variable to “Factor”.  Check the box 
labeled “Estimate effect size for overall tests”.: 

 

 
 

3) Click “Options…”  Check the box labeled “Descriptive”, then click Continue: 
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4) In the “One-Way ANOVA” dialog box, click “Post Hoc…”  Check the box labeled “Tukey”, then 
click “Continue”: 

 

 
5) In the “One-Way ANOVA” dialog box, click “OK”.  The results will appear in the Output window. 
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How to read the output: 

 

 

How to report the results in APA format: 

General format:  F(dfBG, dfWG) = #.##, p = .### 

For this example:  F(2, 6) = 34.915, p < .001 

 

  

This table shows the 
descriptive statistics 
for the DV in the 
different groups. 

Eta-squared is an 
estimate of effect size.  
In this example, eta-
squared equals .921. 



EZ SPSS 4 U    19 

Because the results of the ANOVA are significant, you should look at the results of the post hoc test: 

 

There are no statistics to report in APA format for the post hoc test.  Simply report which means are 
significantly different. 

  

The p-values (Sig.) 
show which pairs of 
sample means are 
significantly different. 

Groups 1 and 2 are 
significantly different. 

Groups 1 and 3 are 
significantly different. 

Groups 2 and 3 are not 
significantly different. 
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One-Way Repeated-Measures (Within-Subjects) ANOVA 
Purpose:  To compare the means of three or more measures that were performed on a single group of 
subjects.  If the ANOVA produces significant results, do a post hoc test to determine specifically which 
sample means are different from each other. 

How to set up the data:  The different measures should be placed in different columns.  Each row 
contains values for a single subject. 

Example:  A group of 5 subjects takes a test at three different times.  Test whether the scores are 
significantly different at different times. 

Example data: 

 

 

How to run the test:   

1) Click on Analyze > General Linear Model > Repeated Measures… to open the dialog box: 
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2) Enter the number of levels of the repeated-measures variable in the “Number of Levels” box, 
then click “Add”: 

 

 
 

3) Click “Define” to open the “Repeated Measures” dialog box: 
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4) Move the three levels of the variable to the “Within-Subjects Variables” box: 

 

 
5) Click “EM Means”.  Move “factor1” to the “Display Means for” box.  Check the “Compare main 

effects” box.  From the “Confidence interval adjustment” drop-down menu, select “LSD(none)”.  
Click “Continue”. 
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6) In the “Repeated Measures” dialog box, click “Options…”  In the “Repeated Measures:  Options” 
dialog box, check “Descriptive statistics” and “Estimates of effect size”.  Click “Continue”: 

 

 

7) In the “Repeated Measures” dialog box, click “OK”.  The results will appear in the Output 
window. 
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How to read the output:  The output will contain many tables.  Only some of the tables contain 
important information for our purposes.  Not all of the tables are shown below. 

 

 

How to report the results in APA format: 

General format:  F(dfBG, dfError) = #.##, p = .### 

For this example:  F(2, 8) = 10.030, p = .007 

 

  

This table shows the 
descriptive statistics for 
the three levels of the 
repeated-measures 
variable. 

Partial eta-squared is a 
measure of effect size.  
In this example, partial 
eta-squared equals .715. 
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Because the results of the ANOVA are significant, you should look at the results of the post hoc test: 

 

There are no statistics to report in APA format for the post hoc test.  Simply report which means are 
significantly different. 

  

The p-values (Sig.) 
show which pairs of 
sample means are 
significantly different. 

Groups 1 and 2 are 
significantly different. 

Groups 1 and 3 are 
significantly different. 

Groups 2 and 3 are not 
significantly different. 
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Two-Way Independent-Groups ANOVA 
Purpose:  To compare the means for a dependent variable when there are two independent variables, 
and there are different subjects in each condition of the experiment.  This allows you to evaluate the 
significance of the two main effects and the interaction. 

How to set up the data:  Each row contains data for a single subject.  One column shows the level of IV1 
that the subject experienced and another column shows the level of IV2 for that subject.  The remaining 
column shows the value of the DV for that subject. 

Example:  All subjects take a math test.  The score on the math test is the DV.  Each subject takes the 
test in either a cold room or a warm room, and either with quiet music or loud music playing.  IV1:  cold 
room or warm room.  IV2:  quiet music or loud music.  There are four groups in this 2x2 design, and 
there are three subjects in each group. 

Example data: 

 

 

How to run the test:   

1) Click on Analyze > General Linear Model > Univariate… to open the dialog box: 
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2) Move the DV to “Dependent Variable” and move the IVs to “Fixed Factor(s)”: 

 

 
3) Click “Options…”  Check the box labeled “Descriptive statistics”, then click Continue: 

 

4) In the “Univariate” dialog box, click “OK”.  The results will appear in the Output window. 



EZ SPSS 4 U    28 

How to read the output: 

 

 

How to report the results in APA format: 

General format:  F(dfBG, dfWG) = #.##, p = .### 

For this example: 

For the main effect of room temp:  F(1, 8) = 12.042, p = .008 

For the main effect of music vol:  F(1, 8) = 15.042, p = .005 

For the interaction:  F(1, 8) = 30.375, p < .001 

This table shows the 
descriptive statistics for 
the DV in the different 
groups, defined by 
different combinations 
of the levels of the IVs. 

Results for the two main 
effects and the interaction 
are in these rows.  (Note 
the “Source” in the first 
column.) 
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Two-Way Repeated-Measures ANOVA 
Purpose:  To compare the means for a dependent variable when there are two independent variables, 
and all subjects experience all levels of both IVs (i.e., the same subjects are in all groups).  This allows 
you to evaluate the significance of the two main effects and the interaction. 

How to set up the data:  Each row contains data for a single subject.  Each column contains the value of 
the DV for one of the combinations of levels of the IVs. 

Example:  All subjects take a test of attention.  The score on the attention test is the DV.  Each subject 
takes the test four times, once in each of the following conditions:  (1) in a cold room with quiet music, 
(2) in a cold room with loud music, (3) in a warm room with quiet music, and (4) in a warm room with 
loud music.  IV1:  cold room or warm room.  IV2:  quiet music or loud music.  There are five subjects and 
four groups (conditions) in this 2x2 design.  Each subject provides a score in each of the four conditions. 

Example data: 

 

 

How to run the test:   

1) Click on Analyze > General Linear Model > Repeated Measures… to open the dialog box: 
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2) For each IV, enter the name of the variable in the “Within-Subject Factor Name” box and the 
number of levels in the “Number of Levels” box, then click on “Add”.  After you have added both 
IVs (as in the box on the right below), click “Define”: 

 

 
3) The “Repeated Measures” dialog box appears: 
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4) Move the four conditions from the left to “Within-Subjects Variables”.  Be sure to keep track of 
the levels of the two variables and move them correctly.  In this example cold = 1, warm = 2, 
quiet = 1, loud = 2.  Move the cold_quiet variable to the Within-Subjects Variable identified as 
(1,1).   

 

 

5) Click “Options…”, check the box labeled “Descriptive statistics”, and click “Continue”: 

 

 

6) In the “Repeated Measures” dialog box, click “OK”.  The results will appear in the Output 
window. 
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How to read the output:  The output will contain many tables.  Only some of the tables contain 
important information for our purposes.  Not all of the tables are shown below. 

 

 

(continued on next page) 

  

This table shows the 
descriptive statistics for 
the DV in the different 
conditions, defined by 
different combinations 
of the levels of the IVs. 
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How to report the first main effect: 

 

 

How to report the results in APA format: 

General format:  F(dfBG, dfError) = #.##, p = .### 

For this example: 

For the main effect of ROOM TEMP:  F(1, 4) = 7.642, p = .051 

 

(continued on next page) 

  



EZ SPSS 4 U    34 

How to report the second main effect: 

 

 

How to report the results in APA format: 

General format:  F(dfBG, dfError) = #.##, p = .### 

For this example: 

For the main effect of MUSIC VOL:  F(1, 4) = 35.266, p = .004 

 

(continued on next page)  



EZ SPSS 4 U    35 

How to report the interaction: 

 

 

How to report the results in APA format: 

General format:  F(dfBG, dfError) = #.##, p = .### 

For this example: 

For the INTERACTION:  F(1, 4) = 0.200, p = .833 
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Two-Way Mixed ANOVA 
Purpose:  To compare the means for a dependent variable when there are two independent variables.  
One of the IVs is manipulated between subjects (as an independent-groups variable) and the other IV is 
manipulated within subjects (as a repeated-measures variable).  This allows you to evaluate the 
significance of the two main effects and the interaction. 

How to set up the data:  Each row contains data for a single subject.  One column contains an identifier 
indicating which level of the independent-groups IV the subject experienced.  Two other columns show 
the value of the DV for the two levels of the repeated-measures IV. 

Example:  All subjects perform a dexterity task.  The score on the dexterity task is the DV.  Half of the 
subjects watch an instructional video before performing the task.  The other half of the subjects do not 
watch an instructional video.  Therefore, “video vs. no video” is an IV manipulated between subjects (as 
an independent-groups variable).  Each subject performs the dexterity task twice, once in a room with 
quiet music playing, and a second time in a room with loud music playing.  Therefore, “music volume” is 
an IV manipulated within subjects (as a repeated-measures variable).  There are four conditions in this 
2x2 design:  (1) video, quiet music, (2) video, loud music, (3) no video, quiet music, and (4) no video, 
loud music.  Each subject provides a score in two of the four conditions.  The numbers in the table are 
the scores on the dexterity task (the DV). 

Example data: 

 

 

  



EZ SPSS 4 U    37 

How to run the test:   

1) Click on Analyze > General Linear Model > Repeated Measures… to open the dialog box: 

 

2) For the repeated-measures IV (music volume), enter the name of the variable in the “Within-
Subject Factor Name” box and the number of levels in the “Number of Levels” box, then click on 
“Add” (to get to the right-hand box below).  Click “Define”: 
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3) The “Repeated Measures” dialog box appears: 

 

 

4) Move the two levels of the repeated-measures variable from the left to “Within-Subjects 
Variables”: 
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5) Move the independent-groups variable to “Between-Subjects Factor(s)”: 

 

 

6) Click “Options…”, check the box labeled “Descriptive statistics”, and click “Continue”: 

 

 

7) In the “Repeated Measures” dialog box, click “OK”.  The results will appear in the Output 
window. 
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How to read the output:  The output will contain many tables.  Only some of the tables contain 
important information for our purposes.  Not all of the tables are shown below. 

 

 

(continued on next page) 

  

This table shows the 
descriptive statistics for 
the DV in the different 
conditions, defined by 
different combinations 
of the levels of the IVs. 
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The following table shows the results for the repeated-measures variable (music_vol) and for the 
interaction: 

 

 

How to report the results in APA format: 

General format:  F(dfBG, dfError) = #.##, p = .### 

For this example: 

For the main effect of MUSIC VOL:  F(1, 6) = 19.652, p = .004 

For the INTERACTION:  F(1, 6) = 0.401, p = .550 

 

(continued on next page) 

  



EZ SPSS 4 U    42 

The following table shows the results for the independent-groups variable (video/no video): 

 

 

 

How to report the results in APA format: 

General format:  F(dfBG, dfError) = #.##, p = .### 

For this example: 

For the main effect of VIDEO_NOVIDEO:  F(1, 6) = 65.000, p < .001 
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Chi-Square (Chi-Square Test of Independence)  
Purpose:  To assess the significance of the relationship between two nominal (categorical) variables. 

You can perform the chi-square test when your data are set up in either of these two ways: 

(1)  When your data table shows the value of each nominal variable for each subject. 
(2)  When your data shows the total number of observations for each combination of values of the 

nominal variables. 

Both are shown below. 

DATA FORMAT OPTION 1  

How to set up the data:  (1)  When your data table shows the value of each nominal variable for each 
subject. 

Organize the data in two columns, one for each nominal variable. Each row represents data for a 
different subject.  

 

Example:  Each subject reports whether they believe they are a dog person or a cat person and whether 
they think they are introverted or extraverted.  

Example data 1:  (There is a total of 20 subjects.  Only some of the data are shown below.) 
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How to run the test: 

1) Click on Analyze > Descriptive Statistics > Crosstabs… The “Crosstabs” dialog box appears:  

 

2) Move one variable to the “Row(s)” box and one variable to the “Column(s)” box:  
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3) Click “Statistics…” Check the box labeled “Chi-square,” then click Continue:  

 

4) In the Crosstabs dialog box, click “OK.” The results will appear in the Output window. 
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How to read the output: 

 

 

How to report the results in APA format: 

General format:  X2(df) = #.##, p = .### 

For this example:  X2(1) = 0.682, p = .409 

 

Note:  As indicated above, if the total in every cell of the contingency table is 5 or greater, use the results 
in the “Pearson Chi-Square” row of the output.  If the total in any cell is less than 5 (as in this example), 
use the results in the “Continuity Correction” row of the output. 

 

(The second way to run the chi-square test is shown on the next page.)  

This table shows the total number of 
subjects for each combination of values 
of the nominal variables.  You will look 
at different numbers in the output 
table below depending on whether any 
cell total is less than 5. 

Use this row if all cell 
totals above are 5 or 
greater. 

Use this row if any cell 
total above is less 
than 5. 
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DATA FORMAT OPTION 2  

How to set up the data:  (2)  When your data show the total number of observations for each 
combination of values of the nominal variables. 

Each variable is represented by a column, and a third column shows a total count or frequency. Each 
row represents a different combination of the levels of both variables. For example, if there are 2 levels 
in each variable, there will be 2x2 = 4 rows; if there are 2 levels in one variable and 3 in the other, there 
will be 2x3 = 6 rows; if there are 3 levels in both variables, there will be 3x3 = 9 rows, and so on… 

 

Example:  Each subject reports whether they believe they are a dog person or a cat person and whether 
they think they are introverted or extraverted.  

Example data 2: 

 

 

How to run the test: 

1) Click on “Data” > “Weight Cases…” The Weight Cases dialog box appears: 
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2) Check “Weight cases by” and move “Count” from the left to “Frequency Variable”, then click 

“OK”: 
 

 
 
 

3) Back in the Data Editor window, click on Analyze > Descriptive Statistics > Crosstabs… The 
“Crosstabs” dialog box appears: 
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4) Move one variable to the “Row(s)” box and one variable to the “Column(s)” box: 

 

 

5) Click “Statistics…” Check the box labeled “Chi-square,” then click Continue: 

 
 

6) In the Crosstabs dialog box, click “OK.” The results will appear in the Output window. 
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How to read the output: 

 

 

How to report the results in APA format: 

General format:  X2(df) = #.##, p = .### 

For this example:  X2(1) = 0.682, p = .409 

 

Note:  As indicated above, if the total in every cell of the contingency table is 5 or greater, use the results 
in the “Pearson Chi-Square” row of the output.  If the total in any cell is less than 5 (as in this example), 
use the results in the “Continuity Correction” row of the output. 

 

 

 

This table shows the total number of 
subjects for each combination of values 
of the nominal variables.  You will look 
at different numbers in the output 
table below depending on whether any 
cell total is less than 5. 

Use this row if all cell 
totals above are 5 or 
greater. 

Use this row if any cell 
total above is less 
than 5. 
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